re = /.*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*/m
str = 'Some text here before at and some more words before another at'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result