use strict;
my $str = 'Some text here before at and some more words before another at';
my $regex = qr/.*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";