# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*Date Ordered:\s*(\d{1,2}\/\d{1,2}\/\d{4}).*|.*/\1/gm;t' <<< "Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative.
Meh Date Ordered: 4/15/1999
irrelevant
--------------Date Ordered: 4/12/3456"