import Foundation
let pattern = #".*Date Ordered:\s*(\d{1,2}/\d{1,2}/\d{4}).*|.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative.
Meh Date Ordered: 4/15/1999
irrelevant
--------------Date Ordered: 4/12/3456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)