#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*Date Ordered:\s*(\d{1,2}/\d{1,2}/\d{4}).*|.*"
Local $sString = "Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative." & @CRLF & _
"Meh Date Ordered: 4/15/1999" & @CRLF & _
"irrelevant" & @CRLF & _
"--------------Date Ordered: 4/12/3456"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)