re = /.*Date Ordered:\s*(\d{1,2}\/\d{1,2}\/\d{4}).*|.*/m
str = 'Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative.
Meh Date Ordered: 4/15/1999
irrelevant
--------------Date Ordered: 4/12/3456'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result