using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Date Ordered:\s*(\d{1,2}/\d{1,2}/\d{4}).*|.*";
string substitution = @"\1";
string input = @"Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative.
Meh Date Ordered: 4/15/1999
irrelevant
--------------Date Ordered: 4/12/3456";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}