#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])\s*[\*x]\s*(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])$"
Local $sString = "[0]*[1]" & @CRLF & _
"[2,3]*[4,5]" & @CRLF & _
"[6, 7, 8] * [9, 10, 11]" & @CRLF & _
"[12,13, 14]* [15, 16,17]" & @CRLF & _
"[0]x[1]" & @CRLF & _
"[2,3]x[4,5]" & @CRLF & _
"[6, 7, 8] x [9, 10, 11]" & @CRLF & _
"[12,13, 14]x [15, 16,17]" & @CRLF & _
"" & @CRLF & _
"[1.2, 3, 4.5] x [6, 7.8, 9]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")