import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[(\\d+|(?:\\d*\\.\\d+))(?:,\\s*(\\d+|(?:\\d*\\.\\d+)))*\\])\\s*[\\*x]\\s*(\\[(\\d+|(?:\\d*\\.\\d+))(?:,\\s*(\\d+|(?:\\d*\\.\\d+)))*\\])$";
final String string = "[0]*[1]\n"
+ "[2,3]*[4,5]\n"
+ "[6, 7, 8] * [9, 10, 11]\n"
+ "[12,13, 14]* [15, 16,17]\n"
+ "[0]x[1]\n"
+ "[2,3]x[4,5]\n"
+ "[6, 7, 8] x [9, 10, 11]\n"
+ "[12,13, 14]x [15, 16,17]\n\n"
+ "[1.2, 3, 4.5] x [6, 7.8, 9]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}