using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])\s*[\*x]\s*(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])$";
string input = @"[0]*[1]
[2,3]*[4,5]
[6, 7, 8] * [9, 10, 11]
[12,13, 14]* [15, 16,17]
[0]x[1]
[2,3]x[4,5]
[6, 7, 8] x [9, 10, 11]
[12,13, 14]x [15, 16,17]
[1.2, 3, 4.5] x [6, 7.8, 9]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}