package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)^(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])\s*[\*x]\s*(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])$`)
    var str = `[0]*[1]
[2,3]*[4,5]
[6, 7, 8] * [9, 10, 11]
[12,13, 14]* [15, 16,17]
[0]x[1]
[2,3]x[4,5]
[6, 7, 8] x [9, 10, 11]
[12,13, 14]x [15, 16,17]
[1.2, 3, 4.5] x [6, 7.8, 9]`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}