#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\\n|\s)*(?<content>.*)"
Local $sString = "save" & @CRLF & _
"" & @CRLF & _
"11" & @CRLF & _
"\nabc" & @CRLF & _
"\nabc" & @CRLF & _
"\nhello" & @CRLF & _
"" & @CRLF & _
"\n\n" & @CRLF & _
"dfcs dcsd" & @CRLF & _
"" & @CRLF & _
"\n\n" & @CRLF & _
"sdcsd" & @CRLF & _
"\nsdcsdc" & @CRLF & _
"\nsdcd" & @CRLF & _
"" & @CRLF & _
"\n" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"\n\n" & @CRLF & _
"11" & @CRLF & _
"\n111" & @CRLF & _
"" & @CRLF & _
"\n\n" & @CRLF & _
"1111" & @CRLF & _
"\n11111" & @CRLF & _
"" & @CRLF & _
"\n\n" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")