import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\\\n|\\s)*(?<content>.*)";
final String string = "save\n\n"
+ "11\n"
+ "\\nabc\n"
+ "\\nabc\n"
+ "\\nhello\n\n"
+ "\\n\\n\n"
+ "dfcs dcsd\n\n"
+ "\\n\\n\n"
+ "sdcsd\n"
+ "\\nsdcsdc\n"
+ "\\nsdcd\n\n"
+ "\\n\n"
+ "1\n\n"
+ "\\n\\n\n"
+ "11\n"
+ "\\n111\n\n"
+ "\\n\\n\n"
+ "1111\n"
+ "\\n11111\n\n"
+ "\\n\\n\n"
+ "1\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}