import re
regex = re.compile(r"^(?:\\n|\s)*(?<content>.*)", flags=re.MULTILINE)
test_str = ("save\n\n"
"11\n"
"\\nabc\n"
"\\nabc\n"
"\\nhello\n\n"
"\\n\\n\n"
"dfcs dcsd\n\n"
"\\n\\n\n"
"sdcsd\n"
"\\nsdcsdc\n"
"\\nsdcd\n\n"
"\\n\n"
"1\n\n"
"\\n\\n\n"
"11\n"
"\\n111\n\n"
"\\n\\n\n"
"1111\n"
"\\n11111\n\n"
"\\n\\n\n"
"1\n\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")