import Foundation
let pattern = #"^(?:\\n|\s)*(?<content>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
save
11
\nabc
\nabc
\nhello
\n\n
dfcs dcsd
\n\n
sdcsd
\nsdcsdc
\nsdcd
\n
1
\n\n
11
\n111
\n\n
1111
\n11111
\n\n
1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)