// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\\n|\s)*(?<content>.*)").unwrap();
let string = "save
11
\\nabc
\\nabc
\\nhello
\\n\\n
dfcs dcsd
\\n\\n
sdcsd
\\nsdcsdc
\\nsdcd
\\n
1
\\n\\n
11
\\n111
\\n\\n
1111
\\n11111
\\n\\n
1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}