using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\\n|\s)*(?<content>.*)";
string input = @"save
11
\nabc
\nabc
\nhello
\n\n
dfcs dcsd
\n\n
sdcsd
\nsdcsdc
\nsdcd
\n
1
\n\n
11
\n111
\n\n
1111
\n11111
\n\n
1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}