re = /^(?:\\n|\s)*(?<content>.*)/m
str = 'save
11
\\nabc
\\nabc
\\nhello
\\n\\n
dfcs dcsd
\\n\\n
sdcsd
\\nsdcsdc
\\nsdcd
\\n
1
\\n\\n
11
\\n111
\\n\\n
1111
\\n11111
\\n\\n
1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end