#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\.{0,1}\/?upgrade[^\w.\s]|\.{0,1}\/?upgrade$)"
Local $sString = "/upgrade/user/Documents" & @CRLF & _
"/upgrade/user/Documents-list_-/" & @CRLF & _
"upgrade/user/Documents-list_-/" & @CRLF & _
"upgrade/" & @CRLF & _
"upgrade /home/user/Documents/file.name" & @CRLF & _
"/upgrade/user/Documents/foo.log" & @CRLF & _
"/upgrade.bar" & @CRLF & _
"/upgrade" & @CRLF & _
"/upgrade/xaf" & @CRLF & _
"/upgradegdfsf" & @CRLF & _
"./upgrade" & @CRLF & _
"./upgrade/srg" & @CRLF & _
"./upgradegdfsf/srgf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")