use strict;
my $str = '/upgrade/user/Documents
/upgrade/user/Documents-list_-/
upgrade/user/Documents-list_-/
upgrade/
upgrade /home/user/Documents/file.name
/upgrade/user/Documents/foo.log
/upgrade.bar
/upgrade
/upgrade/xaf
/upgradegdfsf
./upgrade
./upgrade/srg
./upgradegdfsf/srgf
';
my $regex = qr/(\.{0,1}\/?upgrade[^\w.\s]|\.{0,1}\/?upgrade$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}