// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\.{0,1}\/?upgrade[^\w.\s]|\.{0,1}\/?upgrade$)").unwrap();
let string = "/upgrade/user/Documents
/upgrade/user/Documents-list_-/
upgrade/user/Documents-list_-/
upgrade/
upgrade /home/user/Documents/file.name
/upgrade/user/Documents/foo.log
/upgrade.bar
/upgrade
/upgrade/xaf
/upgradegdfsf
./upgrade
./upgrade/srg
./upgradegdfsf/srgf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}