re = /(\.{0,1}\/?upgrade[^\w.\s]|\.{0,1}\/?upgrade$)/m
str = '/upgrade/user/Documents
/upgrade/user/Documents-list_-/
upgrade/user/Documents-list_-/
upgrade/
upgrade /home/user/Documents/file.name
/upgrade/user/Documents/foo.log
/upgrade.bar
/upgrade
/upgrade/xaf
/upgradegdfsf
./upgrade
./upgrade/srg
./upgradegdfsf/srgf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end