import Foundation
let pattern = #"(\.{0,1}\/?upgrade[^\w.\s]|\.{0,1}\/?upgrade$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/upgrade/user/Documents
/upgrade/user/Documents-list_-/
upgrade/user/Documents-list_-/
upgrade/
upgrade /home/user/Documents/file.name
/upgrade/user/Documents/foo.log
/upgrade.bar
/upgrade
/upgrade/xaf
/upgradegdfsf
./upgrade
./upgrade/srg
./upgradegdfsf/srgf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)