const regex = /(\.{0,1}\/?upgrade[^\w.\s]|\.{0,1}\/?upgrade$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.{0,1}\\\/?upgrade[^\\w.\\s]|\\.{0,1}\\\/?upgrade$)', 'gm')
const str = `/upgrade/user/Documents
/upgrade/user/Documents-list_-/
upgrade/user/Documents-list_-/
upgrade/
upgrade /home/user/Documents/file.name
/upgrade/user/Documents/foo.log
/upgrade.bar
/upgrade
/upgrade/xaf
/upgradegdfsf
./upgrade
./upgrade/srg
./upgradegdfsf/srgf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}