import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.{0,1}\\/?upgrade[^\\w.\\s]|\\.{0,1}\\/?upgrade$)";
final String string = "/upgrade/user/Documents\n"
+ "/upgrade/user/Documents-list_-/\n"
+ "upgrade/user/Documents-list_-/\n"
+ "upgrade/\n"
+ "upgrade /home/user/Documents/file.name\n"
+ "/upgrade/user/Documents/foo.log\n"
+ "/upgrade.bar\n"
+ "/upgrade\n"
+ "/upgrade/xaf\n"
+ "/upgradegdfsf\n"
+ "./upgrade\n"
+ "./upgrade/srg\n"
+ "./upgradegdfsf/srgf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}