#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Tof MS\n).....................[0-9]+"
Local $sString = "1. Q Legionella species kve/liter W57209" & @CRLF & _
"analysis conform, confirmation e.g. NEN-EN-ISO" & @CRLF & _
"11731 using MALDI-Tof MS" & @CRLF & _
"<100 < 100 < 100 < 100" & @CRLF & _
"ties 22" & @CRLF & _
"2. Monstervolume ml" & @CRLF & _
".Activitie" & @CRLF & _
"4. Assessment of AIDS, drinking water decision" & @CRLF & _
"norm 100 kve/litre" & @CRLF & _
"compliant compliant compliant" & @CRLF & _
"Order code" & @CRLF & _
"MonsterCode" & @CRLF & _
"Matrix" & @CRLF & _
"Customer code" & @CRLF & _
"Sample point description" & @CRLF & _
"Sampling date" & @CRLF & _
"Date of receipt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")