import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Tof MS\\n).....................[0-9]+";
final String string = "1. Q Legionella species kve/liter W57209\n"
+ "analysis conform, confirmation e.g. NEN-EN-ISO\n"
+ "11731 using MALDI-Tof MS\n"
+ "<100 < 100 < 100 < 100\n"
+ "ties 22\n"
+ "2. Monstervolume ml\n"
+ ".Activitie\n"
+ "4. Assessment of AIDS, drinking water decision\n"
+ "norm 100 kve/litre\n"
+ "compliant compliant compliant\n"
+ "Order code\n"
+ "MonsterCode\n"
+ "Matrix\n"
+ "Customer code\n"
+ "Sample point description\n"
+ "Sampling date\n"
+ "Date of receipt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}