const regex = /(?<=Tof MS\n).....................[0-9]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Tof MS\\n).....................[0-9]+', 'gm')
const str = `1. Q Legionella species kve/liter W57209
analysis conform, confirmation e.g. NEN-EN-ISO
11731 using MALDI-Tof MS
<100 < 100 < 100 < 100
ties 22
2. Monstervolume ml
.Activitie
4. Assessment of AIDS, drinking water decision
norm 100 kve/litre
compliant compliant compliant
Order code
MonsterCode
Matrix
Customer code
Sample point description
Sampling date
Date of receipt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}