using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Tof MS\n).....................[0-9]+";
string input = @"1. Q Legionella species kve/liter W57209
analysis conform, confirmation e.g. NEN-EN-ISO
11731 using MALDI-Tof MS
<100 < 100 < 100 < 100
ties 22
2. Monstervolume ml
.Activitie
4. Assessment of AIDS, drinking water decision
norm 100 kve/litre
compliant compliant compliant
Order code
MonsterCode
Matrix
Customer code
Sample point description
Sampling date
Date of receipt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}