import Foundation
let pattern = #"(?<=Tof MS\n).....................[0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. Q Legionella species kve/liter W57209
analysis conform, confirmation e.g. NEN-EN-ISO
11731 using MALDI-Tof MS
<100 < 100 < 100 < 100
ties 22
2. Monstervolume ml
.Activitie
4. Assessment of AIDS, drinking water decision
norm 100 kve/litre
compliant compliant compliant
Order code
MonsterCode
Matrix
Customer code
Sample point description
Sampling date
Date of receipt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)