# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\\/|\?[^?]+//gm;t' <<< "https://test.com/foo/bar
https://test.com/foo/bar?param1=test"