#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*\/|\?[^?]+"
Local $sString = "https://test.com/foo/bar" & @CRLF & _
"https://test.com/foo/bar?param1=test"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)