$re = '/.*\/|\?[^?]+/m';
$str = 'https://test.com/foo/bar
https://test.com/foo/bar?param1=test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;