re = /.*\/|\?[^?]+/m
str = 'https://test.com/foo/bar
https://test.com/foo/bar?param1=test'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result