use strict;
my $str = 'https://test.com/foo/bar
https://test.com/foo/bar?param1=test';
my $regex = qr/.*\/|\?[^?]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";