package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\/|\?[^?]+`)
var str = `https://test.com/foo/bar
https://test.com/foo/bar?param1=test`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}