using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/|\?[^?]+";
string substitution = @"";
string input = @"https://test.com/foo/bar
https://test.com/foo/bar?param1=test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}