import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<left>\\{.*(?P<buffer_declaration>char\\s+(?P<buffer_name>\\w+)\\[(?P<buffer_size>\\d+)]\\s*;).*?)(?P<insert_place>\\s)(?P<right>(?P<printing_buffer>\\w*pr\\w*\\(\\s*\\\".*?\\\"[^)]*?(?P=buffer_name).*\\)\\s*;).*\\})";
final String string = "{\n"
+ " char buffer[10];\n"
+ " FILE *file = fopen(\"input.txt\", \"r\");\n"
+ " if (file) {\n"
+ " fread(buffer, 1, 10, file);\n"
+ " fclose(file);\n"
+ " }\n"
+ " printf(\"%s\\n\", buffer);\n"
+ " return 0;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}