import re
regex = re.compile(r"(?P<left>\{.*(?P<buffer_declaration>char\s+(?P<buffer_name>\w+)\[(?P<buffer_size>\d+)]\s*;).*?)(?P<insert_place>\s)(?P<right>(?P<printing_buffer>\w*pr\w*\(\s*\".*?\"[^)]*?(?P=buffer_name).*\)\s*;).*})", flags=re.MULTILINE | re.DOTALL)
test_str = ("{\n"
" char buffer[10];\n"
" FILE *file = fopen(\"input.txt\", \"r\");\n"
" if (file) {\n"
" fread(buffer, 1, 10, file);\n"
" fclose(file);\n"
" }\n"
" printf(\"%s\\n\", buffer);\n"
" return 0;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")