use strict;
my $str = '{
char buffer[10];
FILE *file = fopen("input.txt", "r");
if (file) {
fread(buffer, 1, 10, file);
fclose(file);
}
printf("%s\\n", buffer);
return 0;
}';
my $regex = qr/(?P<left>\{.*(?P<buffer_declaration>char\s+(?P<buffer_name>\w+)\[(?P<buffer_size>\d+)]\s*;).*?)(?P<insert_place>\s)(?P<right>(?P<printing_buffer>\w*pr\w*\(\s*\".*?\"[^)]*?(?P=buffer_name).*\)\s*;).*})/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}