$re = '/(?P<left>\{.*(?P<buffer_declaration>char\s+(?P<buffer_name>\w+)\[(?P<buffer_size>\d+)]\s*;).*?)(?P<insert_place>\s)(?P<right>(?P<printing_buffer>\w*pr\w*\(\s*\".*?\"[^)]*?(?P=buffer_name).*\)\s*;).*})/ms';
$str = '{
char buffer[10];
FILE *file = fopen("input.txt", "r");
if (file) {
fread(buffer, 1, 10, file);
fclose(file);
}
printf("%s\\n", buffer);
return 0;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);