const regex = new RegExp('(?P<left>\\{.*(?P<buffer_declaration>char\\s+(?P<buffer_name>\\w+)\\[(?P<buffer_size>\\d+)]\\s*;).*?)(?P<insert_place>\\s)(?P<right>(?P<printing_buffer>\\w*pr\\w*\\(\\s*\\".*?\\"[^)]*?(?P=buffer_name).*\\)\\s*;).*})', 'gms')
const str = `{
char buffer[10];
FILE *file = fopen("input.txt", "r");
if (file) {
fread(buffer, 1, 10, file);
fclose(file);
}
printf("%s\\n", buffer);
return 0;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}