#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<[^>]+>(*SKIP)(*FAIL)|\b([\pL'’-]{2,})(?![\d\pL])"
Local $sString = "" & @CRLF & _
"<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>" & @CRLF & _
"" & @CRLF & _
"<div>The regex matches compound words and words containing a single quote. Eg: don't, dust-filled.</div>" & @CRLF & _
"<div>It does not select punctuations or inside tags.</div>" & @CRLF & _
"" & @CRLF & _
"<div>If you don't want to select compound words, remove the dash at the end of [\pL'’-] in the regex.</div>" & @CRLF & _
"" & @CRLF & _
"<div>It does not select words containing digits: 123start, start123, sta123rt.</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")