use strict;
my $str = '
<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>
<div>The regex matches compound words and words containing a single quote. Eg: don\'t, dust-filled.</div>
<div>It does not select punctuations or inside tags.</div>
<div>If you don\'t want to select compound words, remove the dash at the end of [\\pL\'’-] in the regex.</div>
<div>It does not select words containing digits: 123start, start123, sta123rt.</div>';
my $regex = qr/<[^>]+>(*SKIP)(*FAIL)|\b([\pL'’-]{2,})(?![\d\pL])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}