import Foundation
let pattern = #"<[^>]+>(*SKIP)(*FAIL)|\b([\pL'’-]{2,})(?![\d\pL])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>
<div>The regex matches compound words and words containing a single quote. Eg: don't, dust-filled.</div>
<div>It does not select punctuations or inside tags.</div>
<div>If you don't want to select compound words, remove the dash at the end of [\pL'’-] in the regex.</div>
<div>It does not select words containing digits: 123start, start123, sta123rt.</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)