const regex = /<[^>]+>(*SKIP)(*FAIL)|\b([\pL'’-]{2,})(?![\d\pL])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]+>(*SKIP)(*FAIL)|\\b([\\pL\'’-]{2,})(?![\\d\\pL])', 'gm')
const str = `
<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>
<div>The regex matches compound words and words containing a single quote. Eg: don't, dust-filled.</div>
<div>It does not select punctuations or inside tags.</div>
<div>If you don't want to select compound words, remove the dash at the end of [\\pL'’-] in the regex.</div>
<div>It does not select words containing digits: 123start, start123, sta123rt.</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}