re = /<[^>]+>(*SKIP)(*FAIL)|\b([\pL'’-]{2,})(?![\d\pL])/m
str = '
<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>
<div>The regex matches compound words and words containing a single quote. Eg: don\'t, dust-filled.</div>
<div>It does not select punctuations or inside tags.</div>
<div>If you don\'t want to select compound words, remove the dash at the end of [\\pL\'’-] in the regex.</div>
<div>It does not select words containing digits: 123start, start123, sta123rt.</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end