import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]+>(*SKIP)(*FAIL)|\\b([\\pL'’-]{2,})(?![\\d\\pL])";
final String string = "\n"
+ "<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>\n\n"
+ "<div>The regex matches compound words and words containing a single quote. Eg: don't, dust-filled.</div>\n"
+ "<div>It does not select punctuations or inside tags.</div>\n\n"
+ "<div>If you don't want to select compound words, remove the dash at the end of [\\pL'’-] in the regex.</div>\n\n"
+ "<div>It does not select words containing digits: 123start, start123, sta123rt.</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}