#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^5$"
Local $sString = "Match ENTIRE LINE of these lines:" & @CRLF & _
"" & @CRLF & _
"1,2,3,4" & @CRLF & _
"-1,2,-3,4,-5" & @CRLF & _
"1000,100,10,1,0" & @CRLF & _
"5" & @CRLF & _
"" & @CRLF & _
"and NONE of these:" & @CRLF & _
"" & @CRLF & _
"2,3," & @CRLF & _
",,," & @CRLF & _
"-,-" & @CRLF & _
"3-2,4-5" & @CRLF & _
"-50,up" & @CRLF & _
"down,20" & @CRLF & _
"apple,banana,pear" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")