import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^5$";
final String string = "Match ENTIRE LINE of these lines:\n\n"
+ "1,2,3,4\n"
+ "-1,2,-3,4,-5\n"
+ "1000,100,10,1,0\n"
+ "5\n\n"
+ "and NONE of these:\n\n"
+ "2,3,\n"
+ ",,,\n"
+ "-,-\n"
+ "3-2,4-5\n"
+ "-50,up\n"
+ "down,20\n"
+ "apple,banana,pear\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}